Skip to end of metadata
Go to start of metadata

Backwards Compatibility Notes


Upgrading from ANY VERSION to 19.1

  • New Message Queue System is a REQUIRED service that needs to be running for FileCloud to be functional from 19.1 onwards
  • Please ensure the Message Queue Service is running after upgrade before opening up for live access
  • You CANNOT upgrade Windows and Linux using the Admin Portal.

Upgrading

As always, make a full backup of your existing installation before upgrading.

You will have to do a full upgrade to 19.1.

Full Upgrade for Windows

You can use the Windows Upgrade tool to do a full upgrade.

Windows Update Tool

Full Upgrade for LINUX

FileCloud provides a script you can run to perform a full upgrade to version 19.1

Full Upgrades on LINUX


Upgrading FileCloud from 17.3 or older to 19.1 in Linux 

If you are using Ubuntu versions earlier than 16.04 or Older versions of Red Hat/CentOS/Fedora, we don't have a script to upgrade your installation to 19.1
You will need to migrate your FileCloud installation manually to Ubuntu 16.04 or Red Hat/CentOS/Fedora that supports PHP 7.1 or greater with the new MongoDB driver to use FileCloud 19.1



Upgrading Systems that use ServerLink to 19.1

To upgrade systems running ServerLink, the following steps should be taken:

  1. Before upgrade, ensure all ServerLink nodes are fully synced and are at the same state.
  2. Make backups of all nodes as needed
  3. Upgrade the master node to 19.1 first
  4. Upgrade each slave to 19.1
  5. Startup all nodes
  • No labels